歡迎來到Linux教程網
Linux教程網
Linux教程網
Linux教程網
Linux教程網 >> Unix知識 >> Unix教程 >> Solaris管理員常用168條命令簡明手冊

Solaris管理員常用168條命令簡明手冊

日期:2017/2/27 17:43:25   编辑:Unix教程
Solaris命令手冊
  SysAdmin Commands
  
  Debugging
  
  truss executable
  /* Trace doing of given command ( useful debugging ) */
  
  truss -f -p
  /* Using multiple windows, this can be used to trace setuid/setgid programs */
  
  Arp, ethernet trouble shooting
  
  arp -a .
  /* Shows the ethernet address arp table */
  
  arp -d myhost
  /* Delete a stale ethernet entry for host myhost */
  
  Disk Commands
  
  du -k .
  /* Reports disk space used in Kilobytes */
  
  du -sk .
  /* Reports only total disk space used in Kilobytes */
  
  du -sk *|sort -k1,1n
  /* Reports total disk space used in Kilobytes in present directory */
  
  du -ad /var | sort -nr
  /* Tells you how big the /var files are in reverse order */
  
  fdformat -d -U
  /* Format diskette */
  
  /usr/bin/iostat -E
  /* Command to display drives statistics */
  
  /bin/mount -F hsfs -o ro /dev/sr0 /cdrom
  /* Mount an ISO 9660 CDROM */
  
  newfs -Nv /dev/rdsk/c0t0d0s1
  /* To view the superfblocks available */
  
  prtvtoc /dev/rdsk/c0t0d0s2
  /* Disk geometry and partitioning info */
  
  quot -af
  /* How much space is used by users in kilobytes */
  
  Driver Parameters
  
  ndd /dev/ip \?
  /* Shows IP variables in the kernel */
  
  ndd /dev/ip ip_forwarding
  /* Tells you if forwarding is on (=1) */
  
  ndd -set /dev/ip ip_forwarding 1
  /* Enables IP forwarding between interfaces */
  
  File Manipulation
  
  dos2unix | -ascii
  /* Converts DOS file formats to Unix */
  
  split
  /* Split files into pieces */
  
  [vi] : %s/existing/new/g
  /* Search and Replace text in vi */
  
  [vi] :set nu
  /* Set line numbers in vi */
  
  [vi] :set ts=[num]
  /* Set tab stops in vi */
  
  File System
  
  cat /dev/null > filename
  /* Zero's out the file without breaking pipe */
  
  dd if=/dev/rdsk/... of=/dev/rdsk/... bs=4096
  /* Make a mirror image of your boot disk */
  
  df -k | grep dg| awk '{print $6}' |xargs -n 1 umount
  /* Unmount all file systems in disk group dg */
  
  fsck -F ufs /dev/rdsk/c0t0d0s0
  /* Check a UFS filesystem on c0t0d0s0 */
  
  fsck -F ufs -y /dev/rdsk/c0t0d0s0
  /* Check answering yes to all questions */
  
  fsck -F ufs -o b=97472 /dev/rdsk/c0t0d0s0
  /* Check using an alternate super block */
  
  gzip -dc file1.tar.gz | tar xf -
  /* Unpack .tar.gz files in place */
  
  gzip -d -c tarball.tgz | (cd /[dir];tar xf - ) &
  /* Unpacking tarballs to diff location */
  
  ln [-fhns]
  /* Creating hard links and soft links */
  
  ls -la | awk '{ print $5," ",$9 }' | sort -rn
  /* File sizes of current directory */
  
  mount -f pcfs /dev/dsk/c0d0p1 /export/dos
  /* Mount DOS fdisk partition from Solaris */
  
  mount -F ufs -o rw,remount /
  /* Used to remount root to make it writeable */
  
  mount -o remount,logging /spare
  /* Re-mount the ro file system rw and turn on ufs logging */
  
  pax -rw . /newdir
  /* Efficient alternative for copying directories */
  
  prtvtoc /dev/rdsk/c0t0d0s2 | fmthard -s - /dev/rdsk/c0t1d0s2
  /* Cloning Partitiontables */
  
  tar cvf filename.tar
  /* Create a tape (tar) archive */
  
  tar xvf filename.tar
  /* Extract a tape (tar) archive */
  
  tar cf - . | (cd /newdir ; tar xf -)
  /* Recursively copy files and their permissions */
  
  /sbin/uadmin x x
  /* Syncs File Systems and Reboots systems fast */
  
  zcat [cpio file] | cpio -itmv
  /* Show the contents of a compressed cpio */
  
  zcat   /* Extract the patch_file that is a compressed tar file */
  
  File Transfer
  
  get filename.suffix |"tar xf -"
  /* Undocumented Feature of FTP */
  
  put "| tar cf - ." filename.tar
  /* Undocumented Feature of FTP */
  
  find . -depth | cpio -pdmv /path/tobe/copied/to
  /* Fast alternative to cp -pr */
  
  sendport
  /* Transferring large numbers of files within the same ftp control session */
  
  General
  
  /usr/bin/catman -w
  /* Create windex databases for man page directories */
  
  FQ_FILENAME=; echo ${FQ_FILENAME%/*}
  /* Extract directory from fully-qualified file name. */
  
  mailx -H -u
  /* List out mail headers for specified user */
  
  set filec
  /* Set file-completion for csh */
  
  uuencode [filename] [filename] | mailx -s "Subject" [user to mail]
  /* Send files as attachments */
  
  Hardware
  
  cfgadm
  /* Verify reconfigurable hardware resources */
  
  m64config -prconf
  /* Print M64 hardware configuration */
  
  m64config -depth 8|24
  /* Sets the screen depth of your M64 graphics accelerator */
  
  m64config -res 'video_mode'
  /* Change the resolution of your M64 graphics accelerator */
  
  Kernel
  
  /usr/sbin/modinfo
  /* Display kernel module information */
  
  /usr/sbin/modload
  /* Load a kernel module */
  
  /usr/sbin/modunload -i
  /* Unload a kernel module */
  
  nm -x /dev/ksyms | grep OBJ | more
  /* Tuneable kernel parameters */
  
  /usr/sbin/sysdef
  /* Show system kernal tunable details */
  
  Memory
  
  prtconf | grep Mem
  /* Display Memory Size */
  
  Network Information
  
  ndd /dev/arp arp_cache_report
  /* Prints ARP table in cache with IP and MAC address */
  
  netstat -a | grep EST | wc -l
  /* Displays number active established connections to the localhost */
  
  netstat -k hme0
  /* Undocumented netstat command */
  
  netstat -i
  /* Show the TCP/IP network interfaces */
  
  netstat -np
  /* Similar to arp -a without name resolution */
  
  netstat -r
  /* Show network route table */
  
  netstat -rn
  /* Displays routing information but bypasses hostname lookup. */
  
  netstat -a | more
  /* Show the state of all sockets */
  
  traceroute
  /* Follow the route to the ipaddress */
  
  Network/Tuning
  
  ifconfig eth0 mtu 1500
  /* Change MTU of interface */
  
  ifconfig eth0 10.1.1.1 netmask 255.255.255.255
  /* Add an Interface */
  
  /sbin/ifconfig hme0:1 inet 10.210.xx.xxx netmask 255.255.0.0 broadcast 10.210.xxx.xxx
  /* Virtual Interfaces */
  
  /sbin/ifconfig hme0:1 up
  /* Bring virtual interface up */
  
  /usr/sbin/ndd -set /dev/hme adv_100fdx_cap 1
  /* Nailling to 100Mbps */
  
  ndd -set /dev/ip ip_addrs_per_if 1-8192
  /* To set more than 256 virtual ip addresses. */
  
  ndd -set /dev/tcp tcp_xmit_hiwat 65535
  /* Increase TCP-transmitbuffers */
  
  ndd -set /dev/tcp tcp_recv_hiwat 65535
  /* Increase TCP-receivebuffers */
  
  Processes
  
  fuser -uc /var
  /* Processes that are running from /var */
  
  kill -HUP `ps -ef | grep [p]roccess | awk '{print $2}'`
  /* HUP any related process in one step */
  
  lsof -i
Copyright © Linux教程網 All Rights Reserved