歡迎來到Linux教程網
Linux教程網
Linux教程網
Linux教程網
Linux教程網 >> Linux基礎 >> 關於Linux >> route TCP/IP index

route TCP/IP index

日期:2017/3/1 11:53:05   编辑:關於Linux

-----------------------------------------------------------------------

Routing TCP/IP Volume 1,Second Edition

------------------------------------------------------------------------

Routing TCP/IP Volume 2

-----------------------------------------------------------------------

-----------------------------------------------------------------------

Routing TCP/IP Volume 1,Second Edition

1. TCP/IP 回顧

OSI TCP/IP

應用層 應用層

表示層

會話層

傳輸層 主機到主機層

網絡層 Internet層

數據鏈路層 網絡接口層

物理層

一些眾所周知的協議號

協議號 主機到主機層協議

1 Internet消息控制協議(ICMP)

2 Internet組管理協議(IGMP)

4 被IP協議封裝的IP

6 傳輸層協議(TCP)

17 用戶數據報協議(UDP)

45 域間路由選擇協議(IDRP)

46 資源預留協議(RSVP)

47 通用路由封裝(GRE)

54 NBMA下一跳解析協議(NHRP)

88 Cisco Internet網管路由選擇協議(IGRP)

89 開放式最短路徑優先(OSPF)

(config)#line vty 0 4

(config-line)#ip netmask-format [decimal | hexadecimal | bit-count]

#debug arp

常用的硬件類型碼

編碼 硬件類型

1 以太網

3 X.25

6 IEEE 802 網絡

15 幀中繼

16 異步傳輸模式(ATM)

17 高速數據鏈路控制(HDLC)

18 光纖信道

19 異步傳輸模式(ATM)

20 串行鏈路

#show arp

C:\windows>arp -a

Linux:~#arp -a

(config)#interface Ethernet 0

(config-if)#arp timeout 1800

(config)#arp 172.21.5.131 0000.00a4.b74c snap

//SNAP (Subnetwork Access protocl)

#clear arp-cache

(config-if)#no ip proxy-arp

(confif-if)#ip gratuitous-arps

#debug ip icmp

#no ip redirects

------------------------------------------------------------------

命令 | 描述

--------------------------------------------------------------------

arp ip-address hardware-address [alias] | 靜態地映射IP地址到硬件地址

arp timeout seconds | 設置Cisco路由器保留ARP表項的時間值

clear arp-cache | 強制從ARP表中刪除所有動態表項

debug ip icmp | 顯示在路由器上出現的ICMP事件

ip address ip-address mask (secondary) | 為接口分配IP地址和掩碼

ip gratuitous-arp | 啟用無故ARP特性

ip netmask-format{bit-count|decimal|hexadecimal} | 配置路由器,使路由器可以用位計數,

| 點分十進制和十六進制方式表示IP(地址,掩碼)對

ip proxy-arp | 啟用代理ARP

ip redirects | 啟用ICMP重定向功能

------------------------------------------------------------------------------

2. IPv6 概述

--------------------------------------------

報頭 下一包頭的值

逐跳可選項 0

路由選擇 43

分段 44

封裝安全有效載荷(ESP) 50

認證包頭(AH) 51

目的地可選項 60

TCP/IP協議 由協議定義的協議號的值(例如 TCP=6,UDP=17,OSPF=89,等)

沒有下一報頭 59

C:\windows>ipv6 nc

#show ipv6 neighbors

C:\windows>ipv6 if 4

interface 4:Ethernet:Local Area Connetion 2

(config)#ipv6 unicast-routing

(config)#ipv6 nd ra-interval

(config)#ipv6 nd ra-lifetime

(config)#ipv6 nd reachable-time

(config)#ipv6 nd ns-interval

(config)#ipv6 nd managed-config-flag

(config)#ipv6 nd other-config-flag

(config-if)#ipv6 nd suppress-ra

(config-if)#ipv6 nd prefix

------------------------------------------------------

3. 靜態路由

------------------------------------------------------

#show ip route

(config)#ip route 192.168.1.0 255.255.255.224 192.168.1.193

(config)#ip route 192.168.1.64 255.255.255.224 192.168.1.193

(config)#ip route 10.4.6.0 255.255.255.0 192.168.1.193

(config)#ip route 10.4.7.0 255.255.255.0 192.168.1.193

(config)#ip route 192.168.1.0 255.255.255.224 serial 0/0

(config)#ip route 10.4.7.0 255.255.255.0 serial 1/0

#show ip route

(config)#ip route 10.1.0.0 255.255.0.0 fastEthernet 0/1 192.168.1.194

#show ip route static

#show arp

(config)#ipv6 unicast-routing

#show cdp neighbor detail

#show ipv6 interface serial 0/0.1

(config)#ipv6 unicast-routing

(config)#interface serial 0/0.2 point-to-point

(config-if)#ipv6 address feco:0:0:3::/64 eui-64

(config)#ipv6 route feco::1:0:0:0:0/64 fec0::3:204:c1ff:fe50:f1c0

(config)#ipv6 route feco::a:0:0:0:0/64 fec0::3:204:c1ff:fe50:f1c0

#show ipv6 route

(config)#ipv6 route feco::a:0:0:0:0/64 serial 0/0.2

(config)#ipv6 route feco::8:0:0:0:0/64 fastEthernet 0/1 fe80::2b:64ff:1:1

#show ipv6 route static

(config)#ip route 192.168.1.0 255.255.255.0 192.168.1.193

(config)#ip route 10.4.0.0 255.255.0.0 192.168.1.193 //靜態路由被匯總

(config)#ipv6 route feco::8:0:0:0:0/62 fec0::3:204:c1ff:fe50:f1c0 //匯總

#debug ip packet

//浮動靜態路由(Floating Static Route)

(config)#ip route 10.4.0.0 255.255.0.0 10.1.10.1

(config)#ip route 10.4.0.0 255.255.0.0 10.1.20.1 50

(config)#ipv6 route fec0:0:0:5::/64 fec0::3:230:94ff:fe24:b780

(config)#ipv6 route fec0:0:0:5::/64 fec0::2:230:94ff:fe24:b780 50

#show ipv6 route static

//Equal-Cost Load Sharing/Unequal-Cost Load Sharing

(config)#ip route 10.1.30.0 255.255.255.0 10.1.10.2

(config)#ip route 10.1.30.0 255.255.255.0 10.1.20.2

#show ip route

#show ipv6 route static

#show ip cef

#show ipv6 cef

(config-if)#ip load-sharing per-packet

(config-if)#ip load-sharing per-destination

#show cef interface {interface}

#show ipv6 cef {interface} detail

#debug ip packet

(config)#interface fastethernet 0/1

(config-if)#no ip proxy-arp

or

(config)#arp 172.16.20.75 0002.6779.0f4c arpa

#show arp

#show ipv6 interface fastethernet 0/1

-----------------------------------------------------------------------

命令 | 描述

---------------------------------------------------------------------

arp ip-address hardware-address | 把IP類型(別名)地址靜態地映射到硬件地址

debug ip packet | 顯示有關接收,生成,轉發IP數據包的信息。

| 而關於快速交換的數據包信息將不被顯示

debug ipv6 packet | 顯示有關接收,生成,轉發IPv6 數據包的信息

ip cef | 為IPv4啟用Cisco急速轉發功能

ip load-sharing {per-packet|per-destination} | 在出站接口上配置負載均衡方式

ip proxy-arp | 啟用代理ARP功能

ip route prefix mask {address|interface[next-hop-address]} [distance]

[permanent][name name][tag tag-number] | 向路由表添加靜態路由

ip route-cache | 再接口上為IPv4配置交換高速緩沖的類型

ipv6 cef | 為Pv6啟用Cisco急速轉發功能。IPv4 的CEF功能必須在IPv6 CEF功能之前打開

ipv6 unicast-routing | 啟用IPv6路由選擇。缺省情況下IPv6 路由選擇是關閉的

ipv6 route prefix/prefix-length {address|interface[next-hop-address]}

[distance][permanent][name name][tag tag-number | 靜態添加IPv6路由

show cdp neighbor detail | 顯示鄰居路由器的IOS版本號以及IPv4和IPv6接口配置等信息

show ip cef | 顯示CEF轉發高速緩沖消息,包括CEF未啟用消息

show ipv6 cef {interface} detail | 顯示接口上CEF功能是否被打開

show ipv6 interface {interface} | 顯示接口以及IPv6特定的接口信息

show ip route | 顯示IP路由表

show ipv6 route | 顯示IPv6路由表

-----------------------------------------------------------------------

4. 動態路由選擇協議

---------------------------------------------------------------------

5. 路由選擇信息協議(RIP)

--------------------------------------------------------------------

#show ip route

(config)#router rip

(config-router)#network 172.17.0.0

(config-router)#passive-interface fastethernet 0/1

(config-router)#neighbor 192.168.12.67

#debug ip rip

#debug ip rip events

(config)#interface fastethernet 0/0

(config-if)#ip address 10.33.55.2 255.255.240.0 secondary

(config)#offset-list {access-list-number|name}{in|out}offset[type number]

(config)#access-list 1 permit 10.33.0.0 0.0.0.0

(config)#router rip

(config-router)#network 10.0.0.0

(config-router)#network 192.168.12.0

(config-router)#offset-list 1 in 2 serial 0/0

#debug ip rip

(config)#interface serial 0/0

(config-if)#ip rip triggered //配置觸發更新,而不是周期性的更新

#debug ip rip

#debug ip rip trigger

(config)#interface serial 0/1

(config-if)#ip rip triggered

-----------------------------------------------------------------

命令 | 描述

-----------------------------------------------------------------

debug ip rip [events] | 簡要地顯示路由器收發的RIP信息

ip address ip-address mask secondary | 在接口上指定一個IP地址作為輔助地址

ip rip triggered | 在某個接口上配置RIP的觸發擴展特性

neighbor ip-address | 通過指定接口鄰居的IP地址來建立鄰接關系

network network-number | 指定一個需要運行RIP的網絡

offset-list {access-list-number|name}{in|out} offset [type number]

| 指定路由表中一個與指定的訪問列表匹配的

| 路由條目,將自己的度量值增加一個指定的

| 偏移量

output-delay delay | 指定一個指定延遲長度的延遲間隙,以便協調

| 高速路由器和低速路由器之間的延遲問題

passive-interface type number | 在指定類型和序列號的接口上阻止RIP廣播

router rip | 啟用RIP進程

timers basic update invalid holddown flush | 修改指定的計時器的值

--------------------------------------------------------------------

6. RIPv2,RIPng 和無類別路由選擇

--------------------------------------------------------------------

(config)#router rip

(config-router)#version 2

(config-router)#network 172.25.0.0

(config-router)#no auto-summary

(config)#router rip

(config-router)#version 1

(config-router)#network 172.25.0.0

(config)#interface fastethernet 0/0

(config-if)#ip address 192.168.50.129 255.255.255.192

(config-if)#ip rip send version 1

(config-if)#ip rip receive version 1 2

(config-if)#no ip split-horizon //關閉水平分割

#debug ip rip

--------------------------------------------------

key chain Bruce

key 1

key-string Keychain1

accept-lifetime 16:30:00 Jul 1 2015 duration 43200

send-lifetime 16:30:00 Jul 1 2015 duration 43200

key 2

key-string Keychain2

accept-lifetime 12:30:00 Dec 31 2015 infinite

send-lifetime 12:30:00 Dec 31 2015 infinite

interface fastethernet 0/0

ip rip authentication key-chain Bruce

ip rip authentication mode md5

--------------------------------------------------

(config)#ipv6 unicast-routing

(config)#interface fastethernet 0/0

(config-if)#ipv6 address 2001:db8:0:6::1/64

(config-if)#ipv6 rip BigMountain enable

#show ipv6 route

(config)#ipv6 router rip SmallMountain

(config-router)#port 527 multicast ff02::9

(config)#ipv6 router rip BigMountain

(config-router)#port 521 multicast ff02::9 //缺省的RIPng端口號(UDP 521)

#show ipv6 rip

#show ipv6 route

#show ipv6 route rip

#debug ipv6 rip

(config)#ipv6 router rip BigMountain

(config-router)#timers 10 30 30 60

(config-rotuer)#maximum-paths 8

(config-router)#distance 200

#show ipv6 rip

(config)#ipv6 router rip BigMountain

(config-router)#no timers 10 30 30 60

(config-rotuer)#no maximum-paths 8

(config-router)#no distance 200

#show ipv6 route rip

(config)#interface fastethernet 1/0

(config-if)#ipv6 rip SmallMountain metric-offset 3

#show ipv6 route rip

(config)#interface fastethernet 0/0

(config-if)#ipv6 address 2001:db8:0:4::2/64

(config-if)#ipv6 rip BigMountain enable

(config-if)#ipv6 rip BigMountain summary-address 2001:db8:0:10::/62

#show ipv6 route rip

#debug ip rip events

linux:~#arp -a

#show ip route

---------------------------------------------------------------

命令 | 描述

---------------------------------------------------------------

accept-lifetime start-time {infinite|end-time|duration seconds}

| 設置一個時間段,用來指定鑰匙鏈上的認證

| 鑰匙可被接受的有效時間

auto-summary | 在網絡邊界打開或關閉自動路由匯總功能

debug ip rip [events] | 啟動RIP處理消息的調試功能

debug ipv6 rip | 啟動RIPng 處理消息的調試功能

ip classless | 使無類路由特性有效,即路由器能夠找到最佳

| 的匹配路由去轉發數據包到目的地址,而不考

| 慮到達目的地址的地址類別

ip rip authentication key-chain name-of-chain | 使接口上的RIPv2認證有效,並

| 指定一個所用的鑰匙鏈的名字

ip rip authentication mode {text|md5} | 指定在一個接口上使用的是明文還是MD5認證

ip rip receive version [1|2] | 指定一個接口可以接收的RIP的版本

ip rip send version [1|2] | 指定一個接口可以發送的RIP的版本

ip split-horizon | 在接口上打開或關閉水平分割特性

ip subnet-zero | 允許接口的地址和路由選擇更新使用全0子網

ipv6 rip process-name enable | 在使用該命令的接口上運行IPv6 RIPng進程,

| 並給它指定一個名字

ipv6 rip process-name metric-offset value | 更改與出站接口相關的度量值

ipv6 rip process-name summary-addres prefix | 把前綴長度較長的前綴匯總成較短的前綴

ipv6 router rip process-name | 在路由器上啟用IPv6 RIPng 進程,並進入可以更改

| 全局RIPng參數的配置模式

port pot-num multicast multicast-value | 更改一個RIPng進程的UDP端口號和(或)多播地址

key number | 指定在鑰匙鏈上的一個鑰匙

key chain name-of-chain | 指定一組鑰匙

key-string text | 指定鑰匙使用的認證字符串或口令

network network-number | 指定覆蓋一個和多個IGRP,EIGRP或RIP協議

| 進程的接口的網絡地址

passive-interface type number | 使一個接口不再發送路由選擇更新

router rip | 在路由器上啟動RIP路由選擇進程

send-lifetime start-time{infinite|end-time|duration seconds}

| 設置一個時間段,用來指定鑰匙鏈上的認證

| 鑰匙可被發送的有效時間

show ip route [address[mask][protocol][process-id] | 顯示當前路由表的全部或某條路由

show ipv6 rip | 顯示RIPng協議的信息

show ipv6 route rip | 顯示通過RIPng協議注入到IPv6路由表中的路由信息

version | 指定RIP路由選擇進程的版本號

-----------------------------------------------------------------------------------------

----------------------------------------------------------------------

7. 增強型內部網關路由選擇協議(EIGRP)

-----------------------------------------------------------------

#show interfaces fastethernet 0/0

(config)#interface fastethernet 0/0

(config-if)#bandwidth 75000

(config-if)#delay 5

#show interfaces fastethernet 0/0

#show interface serial 1/1

#show ip route 172.20.40.0

(config-if)#ip hello-interval eigrp seconds

#show ip eigrp neighbors

#show ip eigrp topology

#show ip route

#debug eigrp packet update query reply

(config)#router eigrp 15

(config-router)#network 172.20.0.0

(config-router)#variance 5 //使用數值為5的差異變量來實現非等價負載均衡

(config-router)#maximum-paths 2

#clear ip rotue *

#show ip route

#debug eigrp neighbor

(config)#router eigrp 15

(config-router)#passive-interface fastethernet 0/1

(config-router)#network 172.20.0.0

(config)#router eigrp 10

(config-router)#passive-interface serial 0/0.1

(config-router)#passive-interface serial 0/0.2

(config-router)#network 10.0.0.0

#show ip eigrp neighbors

(config)#router eigrp 15

(config-router)#network 172.20.15.0 0.0.0.255

(config-router)#no auto-summary

(config-router)#eigrp stub

//eigrp stub {connected|redistributed|static|summary|receive-only}

#show ip eigrp neighbor detail

#show ip eigrp topology

(config)#interface fastethernet 2/2

(config-if)#ip summary-address eigrp 15 172.0.0.0 255.0.0.0

(config-if)#ip summary-address eigrp 15 192.168.16.0 255.255.240.0

#show ip route

key chain Bruce

key 1

key-string Hkey1

interface serial 0/0.1

ip authentication key-chain eigrp 15 Bruce

ip authentication mode eigrp 15 md5

#show ip route

#show ip eigrp neighbors

#debug eigrp packets

#debug ip eigrp neighbor 75 192.168.16.19 //EIGRP 75並且鄰居是192.168.16.19

#debug eigrp neighbors

#debug eigrp packets

(config)#interface fastethernet 0/0

(config-if)#ip access-group 150 in

access-list 150 permit tcp any any established

access-list 150 permit icmp any any

access-list 150 permit eigrp 192.168.16.16 0.0.0.15 any //允許EIGRP數據包

#show ip eigrp neighbors

#show logging

#show ip eigrp topology

(config)#interface serial 3/1

(config-if)#bandwidth 14

(config-if)#ip bandwidth-percent eigrp 15 200 //14kbit/s 的200%,即28kbit/s

------------------------------------------------------------------------

命令 | 描述

------------------------------------------------------------------------

accept-lifetime start-time{infinite|end-time|duration seconds}

| 設置一個時間段,用來指定鑰匙鏈上的

| 認證鑰匙可被接收的有效時間

auto-summary | 在網絡邊界上打開或關閉自動路由匯總

| 功能,這個命令缺省的配置為打開

bandwidth kilobits | 在接口上指定帶寬參數,單位是kbit/s.

| 在一些路由選擇協議中用來計算度量值,

| 但它不影響數據鏈路實際的帶寬

debug eigrp packets | 顯示EIGRP數據包的活動行為

debug ip eigrp neighbor process-id address | 在命令debug eigrp packets 基礎

| 上增加一個過濾器,告訴路由器只顯示

| 選定的進程ID和鄰居的IP數據包

delay tens-of-microseconds | 在接口上指定延時參數,單位是10us.

eigrp stub{connected|redistributed|static|summary|receive-only}

| 配置一台分支路由器作為EIGRP末梢

ip authentication key-chain eigrp process-id key-chain | 在一個運行EIGRP

| 協議的接口上配置一個鑰匙鏈,並

| 指定一個鑰匙鏈所使用的名字

ip authentication mode eigrp process-id md5| 在一個接口上啟用EIGRP協議使用

| 的認證類型

ip bandwidth-percent eigrp process-id percent | 配置EIGRP協議使用的帶寬百分比,

| 缺省配置是50%

ip hello-interval eigrp process-id seconds | 配置EIGRP的hello數據包的時間間隔

ip hold-time eigrp process-id seconds | 配置EIGRP的抑制時間

ip summary-address eigrp process-id address mask | 配置路由器發送一個匯總

| 的EIGRP通告

key number | 指定鑰匙鏈上的一個鑰匙

key chain name-of-chain | 指定一組認證鑰匙

key-string text | 指定鑰匙使用的認證字符或口令

metric weights tos k1 k2 k3 k4 k5 | 指定IGRP和EIGRP協議中計算復合

| 度量值時,對帶寬,負載,延遲和

| 可靠性等參考所使用的權重

network network-number | 指定覆蓋一或多個運行IGRP,EIGRP

| 或RIP協議進程接口的網絡地址

passive-interface type number | 使一個接口不再發送廣播或組播

| 的路由選擇更新

router eigrp process-id | 在路由器上啟動EIGEP路由選擇進程

send-lifetime start-time{infinite|end-time|duration seconds} | 設置一個時間

| 段,用來指定鑰匙鏈上的認證鑰匙可

| 被發送的有效時間

show ip eigrp neighbors [type number] | 用來顯示EIGRP的鄰居表

show ip eigrp topology [process-id][[ip address]mask] | 用來顯示EIGRP的拓撲

| 結構表

timer active-time {minutes|disabled} | 改變或關閉缺省的3min的活動計時

traffic-share{balanced|min} | 指定IGRP協議或EIGRP協議路由選擇

| 進程是否使用非等價負載均衡或只

| 使用等價負載均衡

variance multiplier | 指定一個倍數來表示一條路由與最小

| 代價路徑的度量值得差別程度,確定

| 是否可以依然包含在非等價負載均衡

| “組”中

----------------------------------------------------------------------------

---------------------------------------------------------------

8. 開放最短路徑優先協議(OSPFv2)

----------------------------------------------------------------

#show ip ospf neighbor

#show ip ospf interface Serial 1/1.738

#show ip ospf neighbor 10.7.0.1

#debug ip ospf adj

#show ip ospf database

#show ip ospf database database-summary

#show ip ospf database router 192.168.30.10

#show ip ospf database network 192.168.17.18

#show ip ospf database summary 172.16.121.0

#show ip ospf database asbr-summary

#show ip ospf database external

#show ip ospf database external 10.83.10.0

#show ip ospf database nssa-external

#show ip route

#show ip ospf border-routers

(config)#router ospf 10

(config-router)#network 192.168.30.0 0.0.0.255 area 0

#show ip ospf 10

#show ip ospf neighbor

(config)#ip name-server 172.19.35.2

(config)#ip ospf name-lookup

#show arp

(config)#ip route 192.168.0.0 255.255.0.0 172.19.35.15

(config)#router ospf 10

(config-router)#network 0.0.0.0 255.255.255.255 area 1

(config-router)#area 1 stub no-summary

(config-router)#area 1 default-cost 20

#show ip ospf database database-summary

#show ip route

(config)#router ospf 20

(config-router)#redistribute rip metric 10 metric-type 1 subnets

(config-router)#area 2 nssa no-redistribution no-summary

#show ip route

(config)#router ospf 30

(config-router)#redistribute rip metric 10 metric-type 1 subnets

(config-router)#area 2 nssa no-redistribution default-information-originate

#show ip route

(config)#router ospf 1

(config-router)#area 15 range 10.0.0.0 255.248.0.0

!

(config)#ip route 10.0.0.0 255.248.0.0 Null 0

(config)#router ospf 1

(config-router)#area 15 172.17.0.0 255.255.0.0 not-advertise

(config-router)#area 15 nssa tranlate type 7 suppress-fa

#show ip route

#show ip ospf database external

(config)#router ospf 1

(config-router)#area 25 filter-list prefix area25outbound out

!

(config)#ip prefix-list area25outbound seq 10 deny 192.168.1.0/24

(config)#ip prefix-list area25outbound seq 20 permit 0.0.0.0/0 le 32

(config)#interface fastethernet 0/0

(config-if)#ip ospf authentication-key santafe

(config)#interface serial 0/0.1

(config-if)#ip ospf message-digest-key 10 md5 taos

!

(config)#router ospf 1

(config-router)#area 0 authentication message-digest

!

(config)#service password-encryption

(config)#router ospf 10

(config-router)#area 100 virtual-link 192.168.100.33

!

(config)#router ospf 10

(config-router)#area 100 virtual-link 192.168.100.29

!

#show ip ospf virtual-link

(config)#interface serial 0/0

(config-if)#encapsulation frame-relay

(config-if)#frame-relay map ip 172.16.2.2 100

(config-if)#frame-relay map ip 172.16.2.3 300

!

(config)#router ospf 1

(config-router)#neighbor 172.16.2.2

(config-router)#neighbor 172.16.2.3 priority 10

(config)#interface serial 0/1

(config-if)#encapsulation frame-relay

(config-if)#ip ospf network broadcast

(config-if)#ip ospf priority 0

(config-if)#ip address 172.16.2.1 255.255.255.0

(config-if)#frame-relay map ip 172.16.2.2 100 broadcast

(config-if)#frame-relay map ip 172.16.2.3 300 broadcast

(config)#interface serial 0/0

(config-if)#encapsulation frame-relay

(config-if)#ip ospf network point-to-multipoint non-broadcast

(config-if)#ip address 172.16.2.4 255.255.255.0

!

(config)#router ospf 1

(config-router)#neighbor 172.16.2.1 priority 10

(config)#interface serial 0/1

(config-if)#no ip address

(config-if)#encapsulation frame-relay

(config)#interface serial 0/1.100 point-to-point

(config-if)#description ---------------------------to Hals

(config-if)#ip address 172.16.2.1 255.255.255.252

(config-if)#frame-relay interface-dlci 100

(config)#interface serial 0/1.300 point-to-point

(config-if)#description ---------------------------to Vandyck

(config-if)#ip address 172.16.2.5 255.255.255.252

(config-if)#frame-relay interface-dlci 300

(config)#interface serial 0/0

(config-if)#ip address 172.16.2.1 255.255.255.0

(config-if)#encapsulation frame-relay

(config-if)#ip ospf network point-to-multipoint non-broadcast

(config-if)#ip ospf demand-circuit //運行在按需電路上的OSPF

#show ip ospf database

#debug ip ospf adj

#show logging

#show ip ospf database database-summary

#show ip ospf border-routers

#show ip ospf neighbor

#show ip route

#show ip ospf interface serial 0/0

----------------------------------------------------------------------

命令 | 描述

----------------------------------------------------------------------

area area-id authentication[message-digest] | 使一個區域的類型1或者類型2的認證有效

area area-id default-cost cost | 為ABR路由器發送到一個末梢區域的缺省

| 路由指定一個代價值

area area-id filter-list prefix prefix_list_name [out|in] | 定義一個類型3LSA的過濾列表

area area-id nssa [no-redistribution][default-information-originate][no-summary]

[translate type 7 suppress-fa] | 配置一個區域為非純末梢區域(NSSA)

area area-id range address mask [advertise|not-advertise][cost] | 匯總地址進入或離開

| 一個區域,並可以指定匯總地址的代價

area area-id stub [no-summary] | 配置一個區域作為末梢區域或完全末梢區域

area area-id virtual-link router-id | 在ABR路由器之間定義一條虛鏈路

debug ip ospf adj | 顯示有關一個OSPF鄰接關系的創建或中斷的事件

[no] discard-route {internal|external} | no discard-route去除了自動創建靜態路由到Null接口

ip ospf authentication-key password | 使用類型1的認證方式分配一個口令給一個OSPF接口

ip ospf cost cost | 在一個OSPF接口上指定出站接口的代價大小

ip ospf dead-interval seconds | 在一個接口上指定OSPF的RouterDeadinterval大小

ip ospf demand-circuit | 配置一個接口作為OSPF按需鏈路

ip ospf hello-interval seconds | 為一個接口指定OSPF的HelloInterval的值

ip ospf message-digest-key key-id md5 key | 使用類型2的認證方式指定一個接口的密鑰(口令)

ip ospf name-lookup | 使域名的反向DNS域名查找有效,以便在某些show

| 命令匹配路由器ID

ip ospf network [broadcast][nonbroadcast][point-to-multipoint] | 配置OSPF網絡類型

ip ospf priority number | 設置一個接口的路由器優先級,以便用來

| 選取DR和BDR路由器

ip ospf retransmit-nterval seconds | 設置一個接口的OSPF RxmtInterval值

ip ospf transmit-delay seconds | 設置一個接口的OSPF InfTransDelay值

ip prefix-list prefix_list_name [seq num]{deny|permit} address/length

| 定義一個前綴列表,指定那些地址被允許或拒絕

log-adjacency-changes [detail] | 記錄鄰居狀態的變化

maximum-paths | 設置OSPF執行負載均衡的最大路徑數量

neighbor ip-address [priority number][poll-intervl seconds][cost cost]

| 在一個非廣播網絡上手工配置鄰居路由器

network address inverse-mask area area-id | 指定運行OSPF協議的接口,並指定這些接

| 口相連的OSPF區域

ospf auto-cost reference-bandwidth reference-bandwidth | 為計算鏈路的代價,改變缺省

| 的OSPF參考帶寬

router ospf process-id | 啟動一個OSPF路由選擇進程

show ip ospf [process-id] | 顯示有關OSPF路由選擇進程的一般信息

show ip ospf border-routers | 顯示一台路由器的內部OSPF路由表

show ip ospf [process-id area-id] database | 顯示OSPF鏈路狀態數據庫的所有條目

show ip ospf [process-id area-id] database router [link state-id]

| 顯示OSPF鏈路狀態數據庫中類型1的LSA

show ip ospf [process-id area-id] database network [link state-id]

| 顯示OSPF鏈路狀態數據庫中類型2的LSA

show ip ospf [process-id area-id] database summary [link state-id]

| 顯示OSPF鏈路狀態數據庫中類型3的LSA

show ip ospf [process-id area-id] database asbr-summary [link state-id]

| 顯示OSPF鏈路狀態數據庫中類型4的LSA

show ip ospf [process-id area-id] database nssa-external [link state-id]

| 顯示OSPF鏈路狀態數據庫中類型7的LSA

show ip ospf [process-id] database external [link state-id]

| 顯示OSPF鏈路狀態數據庫中類型5的LSA

show ip ospf [process-id area-id] database database-summary | 根據類型和區域ID

| 顯示OSPF鏈路狀態數據庫中LSA的數量

show ip ospf interface [type number] | 顯示一個接口具體的OSPF信息

show ip ospf neighbor [type number][neighbor-id][detail] | 顯示OSPF鄰居表的信息

show ip ospf virtual-links | 顯示有關OSPF虛鏈路的信息

timer lsa-group-pacing seconds 或 timer pacing lsa-group seconds | 在重刷新計時器

| 超時的兩組LSA之間設定的最小步調時間

---------------------------------------------------------------------------------

9. OPSFv3

----------------------------------------------------------------------

(config)#interface serial 0/0

(config-if)#ipv6 address 2001:db8:0:8::1/64

(config-if)#ipv6 ospf 1 area 1

(config)#interface fastethernet 0/0

(config-if)#ipv6 address 2001:db8:0:4::1/64

(config-if)#ipv6 ospf 1 area 0

#show ipv6 protocol

#show ipv6 ospf neighbor

(config)#ipv6 router ospf 1

(config-router)#area 1 stub no-summary

#show ipv6 route

(config)#interface fastethernet 0/0

(config-if)#ipv6 ospf 1 area 0 instance 1

#show ipv6 ospf interface fastethernet 0/0

(config)#interface serial 0/0

(config-if)#encapsulation frame-relay

(config-if)#ipv6 address 2001:db8:0:1::1/64

(config-if)#ipv6 ospf network broadcast

(config-if)#ipv6 ospf 1 area 1

(config-if)#ipv6 ospf priority 20

(config-if)#frame-relay map ipv6 fe80::206:28ff:feb6:5bc0 201 broadcast

(config-if)#frame-relay map ipv6 fe80::202:fdff:fe5a:a40 202 broadcast

(config-if)#ipv6 ospf neighbor fe80::206:28ff:feb6:5bc0 priority 5

#show ipv6 ospf interface serial 0/0

#show ipv6 ospf neighbor

#show ipv6 route

#debug ipv6 ospf hello

#debug ipv6 ospf adj

#debug ipv6 ospf packet

#show ipv6 interface serial 0/0

----------------------------------------------------------------------

命令 | 描述

----------------------------------------------------------------------

area area-id nssa [no-redistribution][default-information-originate[metric][metric-type]]

[no-summary] | 定義一個非純末梢區域(NSSA區域),並提供一些相

| 關參數的配置選項

area area-id range {ipv6-prefix/prefix-length}[advertise|not-advertise][cost cost]

| 在指定的區域中創建一些具體路由的匯總前綴通告,

| 並擴散到(或者並不擴散,這依賴於選項[advertise|

| not-advertise])其他區域中去

area area-id stub [no-summary] | 定義一個末梢區域或完全末梢區域

debug ipv6 ospf packet | 提供路由器收到的每一個IPv6OSPF數據包的調試信息

debug ipv6 ospf [adj|database-timer|flood|hello|lsa-generation|retransmission]

| 提供具體類型的OSPF數據包的相關調試信息

ipv6 ospf process-id area area-id [instance instance-id] | 創建一個OSPFv3進程(如果還沒有創

| 建的話),並在相應的接口上運行OSPF

ipv6 ospf neighbor ipv6-address [priority number][poll-interval seconds][cost number]

[detabase-filter all out ] | 手工配置OSPFv3的鄰居

ipv6 ospf network {broadcast|non-broadcast}{point-to-multipoint[non-broadcast]|point-to-point}

| 配置OSPF的網絡類型不同於給定傳輸介質支持的缺省類型

ipv6 ospf priority number-value | 配置給定路由器的OSPFv3的優先級,用於DR和BDR路由器

| 的選舉

ipv6 router ospf process-id | 進入OSPFv3路由器配置模式

show ipv6 ospf [process-id][area-id] | 顯示有關OSPFv3進程的一般信息

show ipv6 ospf [process-id][area-id] neighbor [interface-type interface-number][neighbor-id][detail]

| 顯示有關OSPFv3鄰居的一般信息

show ipv6 ospf [process-id][area-id] interface [interface-type interface-number]

| 顯示有關某個具體接口的OSPF信息

summary-prefix prefix [not-avertise|tag tag-value] | 匯總重新分配到OSPFv3當中的前綴

-----------------------------------------------------------------------

10.集成IS-IS協議

-----------------------------------------------------------------------

--------------------------------------------------------------------

命令 | 描述

--------------------------------------------------------------------

address-family ipv6 | 指定跟在其後的命令應用於IPv6地址簇

area-password password | 配置IS-IS區域(第1層)認證

authentication key-chain name-of-chain [level-1 | level-] | 指定預先配置

| 的鑰匙鏈,以便用於對L1或L2的路由器進行

| 認證。L1表示區域范圍的認證,而L2表示

| 域范圍的認證。

authentication mode {md5|text}[level-1|level-2] | 指定用於一個區域或域內路由器

| 之間的認證模式

authentication send-only [level-1|level-2] | 在配置認證而不需要使現有的數據庫

| 無效時使用,這條命令發送認證信息,但不

| 要求接收匹配認證信息

debug isis adj-packets | 顯示IS-IS Hello PDU的行為

debug isis spf-events | 顯示觸發一個IS-IS SPF計算的事件的詳細信息

debug isis snp-packets | 顯示路由器接收和發送SNP的有關信息

debug isis spf-statistics | 顯示一個有關IS-IS SPF計算的統計信息

debug isis spf-triggers | 顯示觸發IS-IS SPF計算的事件

debug isis update-packets | 顯示路由器接收和發送LSP,CSNP和PSNP的有關信息

default-information originate [route-map map-name] | 生成一條進入IS-IS域的缺省IP路由

domain-password password | 配置IS-IS域(L2)認證

ignore-lsp-errors | 配置一台IS-IS路由器忽略錯誤的LSP而不是觸發一個LSP的清除

ip router isis [tag] | 在一個接口上啟動IPv4的IS-IS路由選擇

ipv6 router isis [tag] | 在一個接口上啟動IPv6的IS-IS路由選擇

isis authentication key-chain name-of-chain [level-1 | level-2] | 在某個接口上指定預先

| 配置的鑰匙鏈,以便用於對L1或L2的路由器進行認證。

| L1表示區域范圍的認證,而L2表示域范圍的認證

isis authentication mode {md5|text}[level-1|level-2] | 在某個接口上指定它的認證模式

isis authentication send-only [level-1|level-2] | 在配置認證而不需要中斷現有的鄰接時使用,這條

| 命令發送認證信息,但不要求接收匹配的認證信息

isis csnp-interval seconds {level-1|level-2} | 指定一台IS-IS確定路由器發送CSNP的時間間隔,以秒數計

isis hello-interval seconds {level-1|level-2}| 指定IS-IS Hello PDU重傳的時間間隔,以秒數計

isis hello-multiplier multiplier {level-1|level-2} | 指定一台鄰居路由器在宣告它與始發路由器鄰接關系失效之前,

| 必須錯過的IS-IS Hello PDU的數目

isis lsp-interval milliseconds | 在一個接口上改變LSP的傳輸之間的缺省時延

isis mesh-group [number|blocked] | 給一個接口分配一個數值的mesh組,或在接口上完全阻塞LSP擴散

isis metric default-metric {level-1|level-2} | 指定一個接口的IS-IS缺省度量

isis password password {level-1|level-2} | 在兩台IS-IS鄰居路由器之間配置認證

isis priority value {level-1|level-2}| 指定一個接口用來選取指定路由器的優先級

isis retransmit-interval seconds | 指定一台路由器在一個點到點鏈路上發送一條LSP後需要等待確認

| 的時間,如果超過這個時間還沒有收到確認,路由器將會重傳這條LSP

is-type {level-1|level-1-2|level-2-only} | 配置一台路由器作為一台L1,L1/L2或者L2類型的IS-IS路由器

log-adjacency-changes | 發送所有的鄰接變化事件到日志記錄中

lsp-refresh-interval seconds | 改變本地始發LSP的刷新之間的缺省周期

lsp-gen-interval [level-1|level-2] lsp-max-wait [lsp-initial-wait lsp-second-wait]

| 改變調整LSP生成的指數補償算法的缺省值

max-lsp-lifetime seconds | 改變本地始發LSP的剩余生存時間的缺省值

metric-style [narrow|wide|transition]{level-1|level-2|level-1-2} | 指定所使用的度量風格的類型

multi-topology {transition} | 啟動IPv6的多拓撲

net network-entity-title | 配置一台IS-IS路由器的NET地址

prc-intervl prc-max-wait [pr-initial-wait prc-second-wait] | 指定用於部分路由計算的指數

| 補償算法的缺省值

redistribute isis {ip} level-2 into level-2 distribute-list [access-list number|prefix-list name]

| 啟動從IS-IS level-2進入level-1區域的路由洩漏

router isis [tag] | 啟動一個IS-IS路由選擇進程

set-overload-bit [on-startup{seconds} | wait-for-bgp][suppress{{interlevel}}[external]}]

| 在路由器的LSP中手工設置過載位為1

show clns is-neighbor [type number][detail] | 顯示一個IS-IS鄰居表

show clns protocol | 顯示路由器上如何配置clns和集成IS-IS的信息

show isis database [level-1][level-2][l1][l2][detail][lspid] | 顯示一個IS-IS鏈路狀態數據庫

show isis hostname | 顯示網絡中路由器的系統ID和主機名。這個信息是通過類型137的

| TLV獲取的

show isis ipv6 topology | 顯示IPv6 的拓撲

show isis spf-log | 顯示路由器怎樣以及為什麼要運行一個完全的SPF計算

show isis topology | 顯示IPv4/CLNS的拓撲

spf-interval [level-1|level-2] spf-max-wait [spf-initial-wait spf-second-wait] | 更改用於SPF計算的

| 指數補償算法的缺省參數

summary-address address-mask {level-1|level-1-2|level-2} | 配置IP的地址匯總

summary-prefix ipv6_prefix/prefix_length{level-1|level-1-2|level-2} | 配置IPv6的地址匯總

which-route {nsap-address|clns-name} | 查找並顯示一個指定的CLNS目的地址在路由表中對應的IP地址和

| 區域地址的詳細信息

-----------------------------------------------------------------------------------------------

11.路由重新分配

---------------------------------------------------------------------------

-------------------------------------------------------------------------

命令 | 描述

------------------------------------------------------------------------

default-metric bandwidth delay reliability load mtu | 為重新分配到IGRP和EIGRP的路由指定缺省度量

default-metric number | 為指定分配到OSPF和RIP的路由指定缺省度量

ip summary-address eigrp autonomous-system-number address mask | 在接口上配置一條EIGRP匯總路由

redistribute connected | 重新分配所有直連網絡

redistribute protocol [process-id]{level-1|level-1-2|level-2}[metric metric-value][metric-type type-value]

[match {internal|external 1|external 2}[tag tag-value][route-map map-tag]

[weight weight][subnets] | 配置向一個路由選擇協議重新分配路由,並且指定被重新

| 分配路由的源

summary-address address mask {level-1|level-1-2|level-2} prefix mask[not-advertise][tag tag]

| 為IS-IS和OSPF配置路由匯總

summary-prefix prefix/length {level-1|level-1-2|level-2} | 為IPv6的IS-IS配置匯總路由

summary-prefix prefix/length [not-advertise| tag tag-value] | 為IPv6的OSPFv3配置匯總路由

-------------------------------------------------------------------------------------------

--------------------------------------------------------------------------

12.缺省路由和按需路由選擇

------------------------------------------------------------------------

--------------------------------------------------------------------

命令 | 描述

-------------------------------------------------------------------

cdp enable | 在接口上啟用CDP

cdp run | 在路由器上全局啟用CDP

default-information originate [always][metric metric-value][metric-type metric-value]

{level-1|level-1-2|level-2}[route-map map-name]

| 向OSPF和IS-IS路由選擇域輸入缺省路由

ip classless | 啟用無類別路由查詢,以便路由器可以向直連網絡

| 的未知子網轉發數據包

ip default-network network-number | 在確定最後可選網關時指定一個網絡作為候選路由

ip route address mask {address|interface}[distance][tag tag][permenent] | 指定缺省路由表項

router odr | 啟用按需路由選擇

------------------------------------------------------------------------------------------

------------------------------------------------------------------------

13.路由過濾

------------------------------------------------------------------------

------------------------------------------------------------------------

命令 | 描述

------------------------------------------------------------------------

access-list access-list-number{deny|permit}source [source-wildcard] | 定義標准IP訪問列表表項

distance weight{address mask [access-list-number|name]] | 定義管理距離,該值不同於缺省值

distance eigrp internal-distance external-distance | 為EIGRP內部和外部路由定義管理距離,

| 該值不同於缺省值

distance ospf {[intra-area dist1][inter-area dist2][external dist3]}| 為域內,域間和外部路由定義管理

| 距離,該值不同於缺省值

distribute-list {access-list-number|name} in [interface-name] | 過濾入站IPv4更新路由

distribute-list {access-list-number|name} out [interface-name|routing-process|autonomous-system-number]

| 過濾出站IPv4更新路由

distribute-list prefix-list list_name [in|out] | 過濾IPv6入站或出站更新路由

ipv6 prefix-list list-name [seq num]{deny|permit} prefix/length [ge length|le length] | 定義IPv6前綴列表表項,允許或

| 禁止一個或一組IPv6前綴

redistribute protocol [process-id]{level-1|level-1-2|level-2}[metric metric-value] [metric-type type-value]

[match {internal|external 1|exteranl 2}][tag tag-value][route-map map-tag][weight weight]

[subnets]

| 配置向一路由選擇協議重新分配路由,並指明被重新分配路由的源點

----------------------------------------------------------------------------------------------------------------------

------------------------------------------------------------------------

14.路由映射

-------------------------------------------------------------------------

-------------------------------------------------------------------------

命令 | 描述

------------------------------------------------------------------------

access-list access-list-number {deny|permit} source [source-wildcard] | 定義標准IP訪問列表表項

access-list access-list-number {deny|permit} protocol source source-wildcard destination destination-wildcard

[precedence precedence][tos tos][log] | 定義擴展IP訪問控制列表

ip local policy route-map map-tag | 為路由器產生的數據包定義策略路由

ip policy route-map map-tag | 為經過路由器的數據包定義策略路由

match interface type number [...type number] | 匹配路由,指定接口中的一個接口去往該路由的下一跳

match ip address {access-list-number|name}[...access-list-number|name]| 匹配路由,其中該路由的目標地址被訪問列表指明

match ip next-hop {access-list-number|name}[...access-list-number|name] | 匹配路由,其中該路由的下一跳路由器地址被訪問列表指明

match ip route-source{access-list-number|name}[...access-list-number|name] | 匹配路由,其中通告該路由的路由器被訪問列表指明

match ipv6 address prefix-list {name} | 匹配路由,其中該路由的目標地址被前綴列表指明

match ipv6 next-hop prefix-list {name} | 匹配下一跳路由器地址,其中該路由的目標地址被前綴列表指明

match ipv6 route-source prefix-list{name}| 匹配被路由器通告的路由,其中該路由的目標地址被前綴列表指明

match length min max | 匹配數據包的第3層的長度

match metric metric-value | 匹配指定度量的路由

match route-type {internal|external[type 1|type 2]|level-1|level-2}| 匹配指定類型的OSPF,EIGRP或IS-IS路由

match tag tag-value[...tag-value] | 匹配指定標記的路由

ipv6 prefix-list list-name [seq seq-number]{deny ipv6-prefix/prefix-length|permit ipv6-prefix/prefix-length |

description text}{ge ge-value][le le-value]

| 定義IPv6前綴列表

redistribute protocol [protocol-id]{level-1|level-1-2|level-2}[metric metric-value][metric-type type-value]

[match {internal|external 1|external 2}[tag tag-value][route-map map-tag]

[weight weight][subnets] | 配置進入路由選擇協議的重新分配,並且指明被重新分配路由的源點

set level {level-1|level-2|level-1-2|stub-area|backbone} | 設置IS-IS層或OSPF區域,其中匹配成功的路由將被重新

| 分配進入該區域

set default interface type number[...type number] | 當不存在到達目標網絡的顯示路由時,為匹配成功的數據包設置出站接口

set interface type number[...type number] | 當存在到達目標網絡的顯示路由時,為匹配成功的數據包設置出站接口

set ip default next-hop ip-address[...ip-address] | 當不存在到達目標網絡的顯示路由時,為匹配成功的數據包設置下一跳路由器地址

set ip next-hop ip-address[...ip-address] | 當存在到達目標網絡的顯示路由時,為匹配成功的數據包設置下一跳路由器地址

set ip precedence precedence | 設置被匹配IP數據包服務類型字段中的優先級位

set ip tos type-of-service | 設置被匹配數據包服務類型字段中ToS位

set metric{metric-value|bandwidth delay reliability loading mtu} | 為被匹配路由設置度量值

set metric-type{internal|external|type-1|type-2} | 為將要被重新分配到IS-IS或OSPF的被匹配路由設置度量類型

set next-hop next-hop | 為被匹配路由設置下一跳路由器地址

set tag tag-value | 為被匹配路由設置標記值

-------------------------------------------------------------------------------------------------------

------------------------------------------------------------------------

附錄A 教程:二進制和十六進制

--------------------------------------------------------------------------

-------------------------------------------------------------------------

十六進制 十進制 二進制

0 0 0000

1 1 0001

2 2 0010

3 3 0011

4 4 0100

5 5 0101

6 6 0110

7 7 0111

8 8 1000

9 9 1001

A 10 1010

B 11 1011

C 12 1100

D 13 1101

E 14 1110

F 15 1111

-----------------------------------------------------------------------

-----------------------------------------------------------------------

附錄B 教程:訪問列表

--------------------------------------------------------------------------

------------------------------------------------------------------

Cisco訪問列表編號

---------------------------------------------------------------

訪問列表類型 | 范圍

------------------------------------------------------------

標准IP | 1-99,1300-1999

擴展IP | 100-199,2000-2699

-----------------------------------------------------------------

總結:使用標准列表的過濾器必須被放置在盡可能靠近目標的地方,

而擴展訪問列表可以放置在靠近源點的地方。

--------------------------------------------------------------------------

--------------------------------------------------------------------------

Routing TCP/IP Volume 2

第1章 外部網關協議

-------------------------------------------------------------------------

命令 | 作用

------------------------------------------------------------------------

autonomous-system local-as | 指定EGP路由器所駐留的本地自治系統

debug ip egp transactions | 顯示EGP消息交換和狀態交換的信息

default-information originate | 讓EGP宣告默認路由

neighbor ip-address | 指定EGP鄰居的IP地址

neighbor any [access-list-number|name] | 讓EGP嘗試與發起鄰居獲取協議的所有路由器建立對等關系

neighbor any third-party ip-address [internal|external] | 配置一個間接EGP鄰居

neighbor ip-address third-party third-partyip-address [internal|external]

| 配置EGP發送有關間接鄰居的更新信息

network network-number | 指定應該被宣告給EGP對等體的IGP路由表中的網絡

router egp remote-as | 配置一個EGP路由進程

router egp 0 | 配置一個EGP核心網關進程

show ip egp | 顯示EGP連接及鄰居的相關信息

timers egp hello polltime | 將EGP hello間隔和Poll(輪詢)間隔設置為不同於默認值的值

----------------------------------------------------------------------------------------------

第2章 BGP-4簡介

-------------------------------------------------------------------------

-----------------------------------------------------------------------

第3章 BGP-4的配置及故障檢測

-------------------------------------------------------------------------

命令 | 描述

-----------------------------------------------------------------------

aggregate-address address mask [as-set][summary-only][suppress-map mapname]

[advertise-map map-name][attribute-map map-name]

| 在BGP路由表中創建聚合路由項

auto-summary | 啟用子網的自動匯總功能,匯總為主網地址

bgp always-compare-med | 比較由不同AS中的對等體宣告來的,去往同一目的地的多條路由的MED屬性

bgp bestpath as-path ignore | 讓BGP決策進程忽視AS_PATH的長度

bgp bestpath med confed | 比較由聯盟EBGP對等體宣告來的路由的MED屬性

bgp client-to-client reflection | 啟用IBGP對等體之間的路由反射功能

bgp cluster-id cluster-id | 設置BGP路由反射簇的簇ID

bgp confederation identifier autonomoussystem | 指定聯盟ID(聯盟外部對等體所看見的AS號)

bgp confederation peers autonomoussystem [autonomous-system] | 列出路由器的聯盟EBGP對等體的成員自治系統

bgp dampening [half-life reuse suppress max-suppress-time][route-map map] | 啟用路由阻尼機制並更改路由阻尼的默認值

bgp default local-preference value | 更改LOCAL_PREF的默認值(默認值為100)

bgp deterministic-med | 比較由同一鄰居成員AS中的聯盟EBGP對等體宣告的路由的MED屬性

bgp log-neighbor-changes | 啟用鄰居重置的日志功能

clear ip bgp {*|address|peer-group-name}[soft[in|out]] | 重置一個或多個BGP對等體連接

clear ip bgp dampening [address mask] | 清除BGP阻尼信息,不抑制被抑制路由

clear ip bgp flap-statistics [{regexp regexp}]|{filter-list list}|{address mask} | 清除BGP路由翻動統計

clear ip bgp peer-group peer-group-name | 刪除對等體組中的全部成員

default-information originate | 讓路由器將默認地址0.0.0.0 宣告給其他BGP對等體

default-metric number | 設置由BGP路由器加入到被宣告給EBGP對等體的路由的默認度量值(MED)

distance bgp external-distance internal-distance local-distance | 更改BGP路由的默認管理性距離

ip as-path access-list access-list-number {permit|deny} regexp | 定義一個檢查BGP路由AS_PATH屬性的訪問列表

ip bgp-community new-format | 以AA:NN格式顯示團體屬性

ip community-list community-list-number {permit|deny} community-number | 定義一個利用COMMUNITY屬性來標識BGP路由的訪問列表

ip prefix-list prefix-list-name [seq sequence-number]{permit|deny}{ip-prefix/length}[ge|le] min/max-length

| 定義一個檢查NLRI前綴和長度(在路由中宣告)的訪問列表

match as-path path-list-number | 創建對AS_PATH訪問列表的調用

match community-list community-list-number [exact] | 創建對COMMUNITY訪問列表的調用

neighbor {ip-address|peer-group-name} advertisement-interval seconds | 更改向BGP對等體發送路由更新消息的默認最小宣告間隔

neighbor {ip-address|peer-group-name} default-originate [route-map map-name] | 讓路由器將默認地址0.0.0.0 宣告給指定鄰居或對等體組

neighbor {ip-address|peer-group-name} description text | 為鄰居的配置關聯一個描述文本

neighbor {ip-address|peer-group-name} distribute-list {access-list-number|prefixlist prefix-list-name}{in|out}

| 通過NLRI過濾去往/來自鄰居或對等體組的路由

neighbor {ip-address|peer-group-name} ebgp-multihop hops | 用於更改數據包(攜帶了發送給鄰居的BGP消息)的默認TTL

neighbor {ip-address|peer-group-name} filter-list access-list-number {in|out|weight weight}

| 通過AS_PATH過濾入站或出站BGP路由,或者設置入站路由的權重

neighbor {ip-address|peer-group-name} maximum-prefix maximum [threshold][warning-only]

| 設置最多可以由鄰居或對等體組宣告的NLRI前綴數量

neighbor {ip-address|peer-group-name} next-hop-self | 讓BGP路由器將其自己的地址宣告為學習自EBGP(宣告給IBGP對等體)的NEXT_HOP屬性

neighbor {ip-address|peer-group-name} password string | 在對等體之間啟用MD5驗證機制

neighbor ip-address peer-group peer-group-name | 將某個鄰居分配到對等體組中

neighbor peer-group-name peer-group | 創建一個對等體組

neighbor {ip-address|peer-group-name} prefix-list prefix-list-name {in|out} | 根據NLRI過濾去往/來自鄰居的路由(與通過前綴列表來標識路由一樣)

neighbor {ip-address|peer-group-name} remote-as as-number | 向BGP鄰居表中加入一個鄰居,並將該鄰居標識為EBGP或IBGP鄰居

neighbor {ip-address|peer-group-name} route-map map-name {in|out} | 為去往/來自鄰居或對等體組的路由引用一個設置路由策略的路由映射

neighbor ip-address route-reflector-client | 將路由器配置為路由反射器,並將一個鄰居標識為路由反射客戶端

neighbor {ip-address|peer-group-name} send-community | 標識將那些COMMUNITY屬性發送給鄰居

neighbor {ip-address|peer-group-name} shutdown | 禁用一個鄰居或對等體組

neighbor {ip-address|peer-group-name} soft-reconfiguration inbound | 讓路由器存儲來自指定鄰居的未經修改的更新消息,以用於入站軟重配置操作

neighbor {ip-address|peer-group-name} timers keepalive holdtime | 為鄰居更改默認的保持激活間隔和保持時間間隔

neighbor {ip-address|peer-group-name} update-source interface | 用來標識IBGP更新消息被溯源的接口IP地址

neighbor {ip-address|peer-group-name} version version | 將BGP進程設置為某個版本

neighbor {ip-address|peer-group-name} weight weight | 為接收自鄰居的路由分配權重

network network-number [mask networkmask] | 指定被BGP進程所宣告的網絡

network network-address backdoor | 將指定EBGP路由的管理距離設置為200,並禁止該路由的EBGP宣告

network address mask weight weight [route-map map-name] | 為去往所標識目的地的路由分配權重

router bgp autonomous-system | 在路由器上啟用BGP進程並指定本地AS號

set as-path {tag | prepend as-path-string} | 將被標識路由的AS_PATH設置為重分發標記,或者將指定的一個或多個AS號字符串附加到AS_PATH中

set comm-list community-list-number delete | 從被標識路由的刪除由被調用團體列表所標識的團體屬性

set community {community-number [additive]} |none | 為被標識路由設置團體屬性

set dampening half-life reuse suppress max-suppress-time | 更改被標識路由的默認阻尼要素

set metric-type internal | 設置被標識路由的MED屬性值,以匹配下一跳的IGP度量值

set origin {igp|egp autonomous-system | incomplete} | 更改被標識路由的ORIGIN屬性

set weight weight | 設置被標識路由的權重

show ip bgp [network][networkmask][longer-prefixes] | 顯示整個BGP表

show ip bgp cidr-only | 顯示BGP表中所有攜帶非原始(無類別)網絡掩碼的表項

show ip bgp community {communityname|community-number}[exact] | 顯示BGP表中所有攜帶指定團體屬性的表項

show ip bgp community-list communitylist-number [exact] | 顯示BGP表中所有被指定團體列表所允許的表項

show ip bgp dampened-paths | 顯示被阻尼(被抑制)的路徑

show ip bgp filter-list access-list-number | 顯示BGP表中與指定訪問列表相匹配額表項

show ip bgp flap-statistics [{regexp regexp}|{filter-list list-number}|{address mask}[longer-prefix]}]

| 顯示BGP表中一條或多條表項的路由翻動統計情況

show ip bgp inconsistent-as | 顯示BGP表中擁有多條去往同一目的地的路徑且AS_PATH屬性不一致的表項

show ip bgp neighbors [address][receivedroutes|routes|advertised-routes|{paths regex}|dampened-routes]

| 顯示去往鄰居的TCP連接和BGP連接的信息

show ip bgp paths | 顯示數據庫中的全部BGP路徑

show ip bgp peer-group [peer-groupname][summary] | 顯示被一個對等體組所共享的特性信息

show ip bgp regexp regexp | 顯示BGP表中AS_PATH屬性與指定正則表達式相匹配的表項

show ip bgp summary | 顯示所有BGP連接的相關匯總信息

synchronization | 在BGP和本地IGP之間啟用同步機制

table-map route-map-name | 調用路由映射,以修改進入到IGP路由表中的路由的度量值或標記值

timers bgp keepalive holdtime | 更改整個BGP進程的默認保持激活間隔和保持時間間隔

-------------------------------------------------------------------------------------------------------

------------------------------------------------------------------------

第4章 網絡地址轉換

-------------------------------------------------------------------------

--------------------------------------------------------------------------

命令 | 描述

--------------------------------------------------------------------------

clear ip nat translations {*|[inside[tcp{inside [global-ip [global-port] local-ip [local-port]}|

udp {inside[global-ip [global-port]local-ip [local-port]}]|

[inside global-ip localip][outside local-ip global-ip]

| 清除NAT表中的動態映射表項

ip nat {inside|outside} | 指定內部和外部接口。源自這些接口或發往這些接口的流量都要經過NAT的檢查

ip nat inside destination list {access-listnumber|name} pool name | 啟用內部目的地址的轉換

ip nat inside source {list {access-listnumber|name} pool name [overload]| staticlocal-ip global-ip}

| 啟用內部源地址的轉換

ip nat outside source {list {access-listnumber|name} pool name | static global-ip local-ip}

| 啟用外部源地址的轉換

ip nat pool name start-ip end-ip {netmask netmask|prefix-length prefix-length} type {rotary |match-host}

| 定義一個用於地址轉換的地址池

ip nat translation max-entries entries | 設置NAT表中最大所能允許的映射表項數

ip nat translation {timeout |udp-timeout|dns-timeout|tcp-timeout|finrst-timeout|icmp-timeout|sync-timeout|porttimeout{tcp|udp}} seconds

| 當動態映射表項從NAT表中被刪除,地址又重新回到地址池中之後,更改默認超時周期

show ip nat statistics | 顯示NAT配置的統計匯總信息

show ip nat translations [verbose] | 顯示NAT表

------------------------------------------------------------------------------------------------------------------------------------------

-----------------------------------------------------------------------------

第5章 IP多播路由簡介

--------------------------------------------------------------------------

--------------------------------------------------------------------------

命令 | 描述

--------------------------------------------------------------------------

clear ip cgmp [type number] | 導致發送一條CGMP Leave(離開)消息,作用是清除接收端Catalyst交換機高速緩存中的所有多播組表項

debug ip igmp | 顯示已接收和已發送的IGMP消息以及與IGMP主機相關的事件

debug ip packet [access-list--number|detail] | 顯示已接受和已發送的IP包,可選的訪問列表用於過濾顯示結果中不感興趣的數據包

debug ip pim [group] | 顯示已接收和已發送的PIMv消息以及與PIM相關的事件

ip igmp query-interval seconds | 更改IGMP查詢消息的發送間隔(默認為60秒)

ip igmp query-max-response-time seconds | 更改IGMP查詢消息中所宣告的最大相應時間(默認為10秒)

ip igmp query-timeout seconds | 更改路由器咋接管DR或查詢路由器角色之前等待從DR或查詢路由器接收到IGMP查詢消息的時間(默認為查詢消息的2倍)

ip igmp version {1|2} | 在接口上設置IGMP版本(默認為2)

ip multicast use-functional | 啟用IP多播地址到令牌環功能地址0xC000.0004.0000 的映射

ip pim bsr-candidate type number hash-masklength [priority] | 配置路由器將自己宣告為C-BSR

ip pim message-interval seconds | 更改稀疏模式下Join-Prune消息的發送間隔(默認為30秒)

ip pim query-interval seconds | 更改PIMv2 Hello消息或PIMv1 Router Query(路由器查詢)消息的發送間隔(默認30秒)

ip pim spt-threshold {kbps|infinity} [grouplistaccess-list-number] | 指定PIM-SM路由器從RPT切換到SPT的接收速率閥值(默認為接收到第一個多播包後就進行切換)

ip pim version [1|2] | 設置接口使用PIMv1或PIMv2(默認為2)

show ip igmp groups [group-name|groupaddress|type number] | 顯示學習自IGMP的擁有直連組成員的多播組列表

show ip mroute [group-name|group-address][source][summary][sount][active kbps] | 顯示IP多播路由表的內容

show ip pim neighbor [type number] | 顯示由PIMv1 Router Query(路由器查詢)消息或由PIMv2 Hello 消息發現的鄰居列表

show ip pim rp [group-name|group-address|mapping] | 顯示與多播組或多播路由相關的活動RP

show ip route [address[mask][longerpre fixes]]|[protocol[process-id]] | 顯示單播IP路由表中的路由

--------------------------------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------

第6章 IP多播路由的配置及故障檢測與排除

------------------------------------------------------------------------

-----------------------------------------------------------------------

命令 | 描述

-----------------------------------------------------------------------

ip multicast-routing | 啟用IP多播路由功能

ip routing | 啟用IP單播路由功能

ip pim sparse-mode | 在接口上啟用PIM-SM

ip pim dense-mode | 在接口上啟用PIM-DM

-------------------------------------------------------------------------

第7章 大規模多播路由

------------------------------------------------------------------------

------------------------------------------------------------------------

命令 | 描述

------------------------------------------------------------------------

address-family {ipv4|vpnv4}{multicast|unicast|vrf} | 啟用MBGP

exit-address-family | 標記MBGP配置片段的結束

ip mroute source mask [protocol asnumber]{rpf-address|type number}[distance]

| 配置一條用於RPF檢查的多播路由

ip msdp cache-sa-state [list access-listnumber] | 啟用SA緩存

ip msdp default-peer ip-address|name [prefix-list list] | 指定一個不執行RPF檢查即可

| 接收SA消息的MSDP對等體

ip msdp description {peer-name|peeraddress} text | 給MSDP對等體配置增加描述性文本

ip msdp filter-sa-request {ip-address|name} [list access-list-number]

| 為出站SA Request消息啟用一個過濾器

ip msdp mesh-group name {ip-address|name} | 將對等體指派為網狀多播組的成員,來自網狀多播組某個成員的SA

| 消息不會轉發給該網狀多播組的其他成員

ip msdp originator-id type number | 更改MSDP消息中使用的默認RP地址

ip msdp peer {peer-name|peer-address}[connect-source type number][remote-as as-number]

| 將路由器指派為MSDP對等體

ip msdp redistribute [list access-list-name][asn aspath-access-list-number][routemap map]

| 為本地路由器發起的MSDP SA消息啟用一個過濾器

ip msdp sa-filter in {ip-address|name}[list access-list-name][route-map map-tag] | 為入站MSDP SA消息啟用一個過濾器

ip msdp sa-filter out {ip-address|name}[list access-list-name][route-map maptag] | 為出站MSDP消息啟用一個過濾器

ip msdp sa-request {ip-address|name} | 讓RP向指定的緩存對等體發送MSDP SA Request消息

ip msdp ttl-threshold {ip-address|name} ttl | 為本地路由器發起的MSDP消息設置TTL值

ip multicast boundary access-list-number | 將某接口指定為多播邊界以進行多播定界

ip multicast ttl-threshold ttl-value | 將某接口指定為多播邊界以進行TTL定界

neighbor {ip-address|name} activate | 將被激活的MBGP鄰居指定為僅用於單播,僅用於多播或同時用於單播和多播

no bgp default ipv4-unicast | 禁用將所有BGP鄰居都指派為單播鄰居的默認行為,從而可以獨立激活單播鄰居

show ip msdp peer peer-address|name | 顯示MSDP對等體的詳細信息

show ip msdp sa-cache [group-address|source-address|group-name|source-name][group-address|source-address|groupname|source-name]

[autonomous-systemnumber] | 顯示緩存在本地路由器中的SA狀態信息

show ip msdp summary | 顯示MSDP對等體的匯總信息

-------------------------------------------------------------------------------------------------------------------------------

-------------------------------------------------------------------------

第8章 IPv6

------------------------------------------------------------------------

------------------------------------------------------------------------

命令 | 描述

-------------------------------------------------------------------------

ipv6 unicast-routing | 在全局命令模式啟用IPv6

ipv6 enable | 在接口上啟用IPv6

-------------------------------------------------------------------------

----------------------------------------------------------------------------

第9章 路由器管理

-------------------------------------------------------------------------

------------------------------------------------------------------------

命令 | 描述

-------------------------------------------------------------------------

snmp-server community communitystring [view view-name][ro|rw][accesslist number]

| 定義團體字符串,使用該團體字符串的可用預定義視圖,該團體字符串所允許的接入類型(ro|或rw),

| 相關聯的訪問列表,並指定允許使用該團體字符串的設備

snmp-server view view-name oid-tree [included|excluded} | 限制SNMP管理器可以訪問的MIB對象

snmp-server system-shutdown | 讓SNMP管理器通過SNMP向登錄到路由器的用戶發送一條消息,之後再重啟該路由器

snmp-server tftp-server-list accesslist_number | 限制TFTP服務器通過SNMP將配置文件加載到訪問列表所指定的服務器上的能力

snmp-server host host [version{1|2c}] community-string [udp-port port][trap-type] | 指定trap所要發送到的主機

snmp-server enable traps trap-type trap-option | 讓所列類型的trap都可以被發送

snmp trap link-status | 在接口上啟用鏈路有效/失效trap

show snmp | 顯示SNMP統計情況

rmon alarm number variable interval {delta|absolute} rising-threshold value [event-number]falling-threshold value [event-number][owner string]

| 定義一個告警,並指定何時觸發和清除告警,以及什麼事件將觸發告警

rmon event number [log][trap community][description string][owner string]

| 定義一個RMON事件並指定在何時記錄該事件(當該事件被某個告警觸發後)

show rmon alarms | 顯示已定義告警的信息

show rmon events | 顯示事件表

logging buffered [size] | 啟用有緩存的登錄路由器並指定日志的大小

show logging | 顯示已被緩存的日志

clear logging | 清除已被緩存的日志

logging host | 指定將要接收syslog消息的主機名或主機的IP地址

terminal monitor | 將日志消息發送到當前終端行

service timestamps log uptime | 為日志增加時間戳

service timestamps log datetime[msec][localtime][show-timezone] | 為日志增加時間戳

logging console level | 限定記錄到控制台的消息

logging monitor level | 限制記錄到終端行的消息

logging trap level | 限制記錄到Syslog服務器的消息

logging facility facility-type | 定義將日志消息發送給Syslog服務器所使用的服務類型

snmp-server enable traps syslog | 啟用Syslog消息的SNMP trap

logging history level | 指定通過SNMP發送的Syslog消息的等級

ntp server ip_address [version number][key keyid][source interface][prefer] | 創建一個服務器關聯,以便讓路由器能將其時鐘與其他NTP時鐘源實現同步

ntp peer ip_address [version number][key keyid][source interface][prefer] | 創建一個對等體關聯,以便讓該路由器能將其時鐘與其他設備實現同步,

| 或者讓其他設備能夠與其實現同步

ntp access-group {query-only|serveronly|serve|peer} access-list-number | 控制對路由器的NTP服務的訪問

clock calendar-valid | 將路由器的日歷啟用為一個授權時間源

ntp master [stratum] | 將IOS配置為NTP主時鐘(對等體與其進行同步)

ntp update-calendar | 利用學習自NTP的時間/日期來更新路由器的日歷

ntp authenticate | 在全局范圍啟用NTP認證密鑰

ntp authentication-key number md5 key | 定義NTP認證密鑰

ntp trusted-key number | 該命令列出了已在命令ntp authentication-key 中定義了的密鑰號,在該路由器與NTP服務器

| 實現同步之前,該NTP服務器必須包含在其NTP包中

ip accounting | 在接口上啟用IP記賬功能

ip accounting-threshold threshold | 設置記賬表中可以存儲的最大表項數

show ip accounting [checkpoint][access-violations] | 顯示IP記賬數據

clear ip accounting | 清除IP記賬數據

ip route-cache flow | 在接口上啟用NetFlow機制

ip flow-export destination ip-address udp-port | 為接收NetFlow數據的主機指定IP地址和UDP端口號

ip flow-export [version 1|version 5[origin-as|peer-as]] | 指定向流采集器發送數據時使用NetFlow版本以及發送那些AS號、流量的發信AS或路由器的對等體AS

show ip flow export | 顯示數據導出方式的相關信息

show ip cache flow | 顯示被導出的數據

ip cef | 在全局范圍內以及所有支持CEF的接口上啟用CEF

ip flow-aggregation cache {as|destination-prefix|prefix|protocol-port|source-prefix}

| 定義一個聚合NetFlow緩存

cache entries number_of_entries | 定義聚合緩存中的最大表項數

cache timeout inactive seconds | 定義聚合緩存中非活動表項的超時值

cache timeout active minutes | 修改活動表項保持有效的分鐘數

export destination ip_address udp_port | 為聚合緩存指定導出目的地

enabled | 啟用聚合緩存

show ip cache flow aggregation as | 顯示AS緩存數據

show ip cache flow aggregation destination-prefix | 顯示目的前綴緩存數據

show ip cache flow aggregation source-prefix | 顯示源前綴緩存數據

show ip cache flow aggregation protocol-port | 顯示協議端口緩存數據

enable-secret password | 定義啟動級密碼

service password-encryption | 在查看配置時對密碼進行加密

access-class access-list_1-199_or_1300_2699[in|out] | 在允許入站或出站終端會話前指定一個所要使用的訪問列表

transport input telnet ssh | 限制允許建立終端會話的協議

transport input none | 在所配置的命令行上禁止所有的終端協議

exec-timeout | 為非活動終端會話定義超時值

service tcp-keepalives-in | 在入站連接中啟用TCP保持激活消息

no ip directed-broadcast | 在接口上禁用定向廣播

scheduler interval milliseconds | 配置路由器停止處理中斷請求的間隔,並按照此間隔處理其他商業事務

scheduler allocate interrupt-time process-time | 定義路由器在任意網絡中斷上下文中完成快速交換所需的最大時間,以及禁用網絡

| 中斷時路由器在進程級所需的最短時間

no service tcp-small-servers | 禁用TCP小型服務器

no service udp-small-servers | 禁用UDP小型服務器

no service finger | 禁用Finger服務器

no ip bootp server | 禁用BOOTP服務器

aaa new-model | 啟用AAA

aaa authentication login {default|list_name} group auth_type [auth_type ...] | 定義AAA認證方法列表

login authentication list_name | 指定在認證連接用戶時所使用的已定義的AAA認證方法列表

tacacs-server host ip_address | 定義TACACS服務器

radius-server host ip_address | 執行RADIUS服務器

tacacs-server key key | 定義路由器與TACACS服務器之間使用的共享密鑰

radius-server key key | 定義路由器與RADIUS服務器之間使用的共享密鑰

aaa authentication enable default group auth_type [auth_type] | 定義啟用級訪問所使用的認證類型

aaa authorization {network|exec|commands level|reverse-access}{default|list-name}[method1[method2...]]

| 定義AAA認證方法列表

authorization {arap|exec|commands level|reverse-access}{default|listname} | 指定在認證連接用戶時所使用

| 的已定義的AAA授權方法列表

aaa accounting {system|network|exec|connection|commands level}{default|list-name}{start-stop|wait-start|stoponly|none}

{method1[method2...]] | 定義AAA記賬方法列表,定義所要記賬的信息類型

accounting {arap|exec|connection|commands level}{default|list-name} | 指定在認證連接用戶時所使用的已定義的AAA記賬方法列表

hostname hostname | 定義路由器的主機名(生成RSA密鑰時需要)

ip domain-name domainname | 定義路由器的域名(生成RSA密鑰時需要)

crypto key generate rsa | 生成RSA密鑰(並啟用SSH)

ip ssh {[timeout seconds]|authentication-retries integer]} | 修改SSH參數

standby [group-number] ip [ip-address[secondary]] | 為指定備用組定義HSRP地址

standby [group-number] timers hellotime holdtime | 為指定備用組修改定時器

standby [group-number] priority priority [preempt[delay delay]] | 修改指定備用組中的路由器的優先級,並指定搶占特性

standby [group-number] [priority priority] preempt [delay delay]| 指定搶占特性,並修改指定備用組中的路由器的優先級

standby [group-number] track type number [interface-priority] | 標識一個備用被跟蹤的接口

standby [group-number] authentication string | 定義一個備用認證字符串

standby use-bia [scope interface] | 將固化(burnt-in)地址作為備用MAC地址

show standby | 顯示當前的HSRP屬性

-------------------------------------------------------------------------------------------------------------------------

-------------------------------------------------------------------------

附錄A 命令 show ip bgp neighbors 的顯示內容

------------------------------------------------------------------------

show ip bgp neighbors 10.100.1.1

-----------------------------------------------------------------------

附錄B 正則表達式教程

--------------------------------------------------------------------------

------------------------------------------------------------------------

表B-1 與AS_PATH 訪問列表相關的正則表達式中的元字符

------------------------------------------------------------------------

元字符 |  匹配什麼

------------------------------------------------------------------------

. | 任何單字符,包括空格

[] | 任何列於方括號內的字符

[^] | 任何字符(列於方括號之內的除外)(^要位於直接量序列之前)

- | (連字符)位於被連字符分割的兩個直接量之間的任何字符

? | 0或一個字符(或模式)實例

* | 0或多個字符(或模式)實例

+ | 一個或多個(或模式)實例

^ | 行起始

$ | 行結束

| | 被元字符隔開的兩個直接量之一

_ | (下劃線)逗號、行的起始、行的結束或空格

--------------------------------------------------------------------------

--------------------------------------------------------------------------

符錄C 保留的多播地址

------------------------------------------------------------------------

-----------------------------------------------------------------------

224.0.0.1 All Systems on this Subnet

224.0.0.2 All Routers on this Subnet

224.0.0.4 DVMRP Routers

224.0.0.5 OSPFIGP OSPFIGP All Routers

224.0.0.6 OSPFIGP OSPFIGP Designated Routers

224.0.0.9 RIP2 Routers

224.0.0.10 IGRP Routers

224.0.0.12 DHCP Server/Relay Agent

224.0.0.13 All PIM Routers

224.0.0.18 VRRP

224.0.0.22 IGMP

224.0.0.25 router-to-switch

224.0.1.1 NTP Network Time Protocol

224.0.1.9 MTP Multicast Trandport Protocol

224.0.1.24 microsoft-ds

224.0.1.39 cisco-rp-announce

224.0.1.40 cisco-rp-discovery

224.0.1.141 DHCP-SERVERS

-----------------------------------------------------------------------

-----------------------------------------------------------------------

Copyright © Linux教程網 All Rights Reserved